ref通达信公式,通达信编写公式错误提示:REF (MACD,DEA,1)<0 AND MACD.DEA>...

内容导航:
  • 通达信编写公式错误提示:REF (MACD,DEA,1)<0 AND MACD.DEA>...
  • 请问通达信公式:1、 MA5>REF(MA5,1) AND MA10>REF(MA10,...
  • 指标公式中ref:(close,10:)表示什么?
  • 请问老师 下面这个函数的具体意义是什么?通达信 REF(X,A)函数?
  • 通达信中DAY!=REF(DAY,1)是什么意思
  • 通达信L<REF(L,1) AND REF(L,1)<REF(L,2); 和 DOWNN...
  • Q1:通达信编写公式错误提示:REF (MACD,DEA,1)<0 AND MACD.DEA>...

    在编写公式过程中,要注意标点符号,每个符号都有不同的功能,用错或位置不对都不能正常识别;你这段错误的原因是引用的过程中,将点号输成了豆号,自然无法识别:

    REF (MACD,DEA,1)<0 AND MACD.DEA>0;

    正确的源码如下:

    ref(macd.dea,1)<=0 and macd.dea>=0;

    这就是正确的表达DEA拐头向上的源码;

    Q2:请问通达信公式:1、 MA5>REF(MA5,1) AND MA10>REF(MA10,...

    MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1);
    MA(C,5)>MA(C,10)
    MA5>1日前的MA5 AND MA10>1日前的MA10 AND MA20>1日前的MA20
    收盘价的5日简单移动平均>收盘价的10日简单移动平均
    就是这个意思,你不懂均线,问这些也没有意义。

    Q3:指标公式中ref:(close,10:)表示什么?

    1、正确的书写方法如下(通达信软件):

    ref(close,10);

    2、关于REF函数的介绍如下(通达信软件):

          引用若干周期前的数据(平滑处理).
          用法:
               REF(X,A),引用A周期前的X值.A可以是变量.
          平滑处理:当引用不到数据时进行的操作。此函数中,平滑时使用上一个周期的引用值。
          例如:REF(CLOSE,BARSCOUNT(C)-1)表示第二根K线的收盘价.

    3、公式的意思是,引用十天前的收盘数据作为参考使用;

    4、如果对公式函数不了解,可以多看看他们的功能和用法,为了实现一个目标,有时会串用几个函数,所以,了解单一函数功能后需要学会怎么样去使用;

    Q4:请问老师 下面这个函数的具体意义是什么?通达信 REF(X,A)函数?

    REF(HHV(H,0),1);
    你的这个语句的意思是:[昨日0日内最高价的最高值]。

    Q5:通达信中DAY!=REF(DAY,1)是什么意思

    您好
    您可以参考
    第一个用于60分钟的没有显示,不知道是怎么回事
    {用于60分钟} X1:=BARSLAST(DAY!=REF(DAY,1))+1;
    {算基准量比} X2:=(SUM(V,20+X1)-SUM(V,X1))/5;
    {小时分量比} LB:V/X2,NODRAW;
    {收盘总量比} ZLB:IF(HOUR=15,SUM(LB,4),1/0),NODRAW; {收盘的全天4小时总量比数值相加等于全天的量比数值}
    收盘总量比可否帮我合成一下
    这是我合成的一个:LB:V/(SUM(V,20+(BARSLAST(DAY!=REF(DAY,1)))+1)-SUM(V,(BARSLAST(DAY!=REF(DAY,1)))+1)/5),NODRAW;

    Q6:通达信L<REF(L,1) AND REF(L,1)<REF(L,2); 和 DOWNN...

    L<REF(L,1) AND REF(L,1)<REF(L,2);
    DOWNNDAY(L,3);
    L<REF(L,1) AND REF(L,1)<REF(L,2);
    这行条件是要求最低价一天比一天低,无论涨跌。
    DOWNNDAY(L,3); 这个是最近3日最低价一天比一天低,并且连跌。

    上一篇:上一篇:李嘉诚炒股吗
    下一篇:下一篇:股市里的钱怎么转出来
    • 评论列表

    发表评论: